Nodestream Meta Plugin
This plugin allows you to build a Graph of your Graph's Schema.
Installation
pip install nodestream-plugin-meta
Meta-Schema
The schema of the graph schema is as follows:
For extra meta characteristics, the schema of the schema schema is also added to the projects schema like any other pipeline.
In other words, the types NodeType, Property, and so on are added to the schema of the graph.
Getting Started
Unlike other schema plugins, this plugin uses the ingestion system to build the metagraph in your graph. That means that you need to build a pipeline to do the ingestion. For the simple case, you can build a single step pipeline that looks like this:
- implementation: nodestream_plugin_meta:SchemaRenderer
This will locate the project file located inside the current working directory (or its parent directories) and render the schema to the graph. You can also specify the path to the project file:
- implementation: nodestream_plugin_meta:SchemaRenderer
parameters:
project_path: /path/to/nodestream.yaml
You may also specify an overrides file to enrich the inferred schema:
- implementation: nodestream_plugin_meta:SchemaRenderer
parameters:
project_path: /path/to/nodestream.yaml
overrides_path: /path/to/overrides.yaml
The overrides file should look like this:
nodes:
- name: Person
properties:
is_cool:
type: BOOLEAN
relations:
- name: Knows
properties:
since:
type: DATE
The file is merged with the inferred schema, so you can add new nodes, relations, or properties, or override parts of existing ones.
Querying the Meta Graph
The meta graph can be queried like any other graph data. For example, to get all the node types in the graph:
MATCH (n:NodeType) RETURN n.name
Or to get all the properties of a node type:
MATCH (n:NodeType {name: 'Person'})-[:HAS_PROPERTY]->(p:Property) RETURN p.name, p.type, p.is_key
Same goes for relations and their properties:
MATCH (r:RelationshipType {name: 'Knows'})-[:HAS_PROPERTY]->(p:Property) RETURN p.name, p.type, p.is_key
Also you can get the adjacencies the graph schema:
MATCH (a:NodeType)<-[:TO|FROM]-(adj:Adjacency)-[:TO|FROM]->(b:NodeType)
MATCH (adj)-[:THROUGH]->(r:RelationshipType)
RETURN a.name, r.name, b.name
Metadata
Release files for nodestream-plugin-meta 0.16.0
For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.
Source distribution (sdist)
| File | Size | Uploaded | Provenance | |
|---|---|---|---|---|
| nodestream_plugin_meta-0.16.0.tar.gz | 7.3 kB | With provenance | Details |
Built distribution (wheel)
| File | Interpreter | ABI | Platform | Reset |
|---|---|---|---|---|
| nodestream_plugin_meta-0.16.0-py3-none-any.whl | Python 3 | none | any | Details |
Total release size: 15.8 kB
Release files / nodestream_plugin_meta-0.16.0.tar.gz
| Download URL | nodestream_plugin_meta-0.16.0.tar.gz |
|---|---|
| Size | 7.3 kB |
| Tags | Source |
|
SHA-256 checksum How to use checksums |
7583ec9c791f5e1e1f758a3dbb6bbf661a5608202271027cc027f8a008a5e6b2
|
|
BLAKE2b-256 checksum How to use checksums |
286c1748ea16de24b5bbd5ed9003bec1655266fa938ddf2e03cdfefbb171552e
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/6.1.0 CPython/3.13.12
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Jun 24, 2026.
Transparency logRelease files / nodestream_plugin_meta-0.16.0-py3-none-any.whl
| Download URL | nodestream_plugin_meta-0.16.0-py3-none-any.whl |
|---|---|
| Size | 8.5 kB |
| Tags | Python 3 |
|
SHA-256 checksum How to use checksums |
21e56bdcdcb2fc14bcf4c0af6b4fe8854df77409acff6111dfcaf42e532ebf2e
|
|
BLAKE2b-256 checksum How to use checksums |
98470d6eb33fe147155ddb7712cba51e2c3f2f82108c78ae6de85a214b066108
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/6.1.0 CPython/3.13.12
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Jun 24, 2026.
Transparency logSecurity for nodestream-plugin-meta 0.16.0
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
Full provenance
All 2 files in this release have been uploaded with provenance metadata.
Attestation for nodestream_plugin_meta-0.16.0.tar.gz
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Jun 24, 2026.
Transparency logA note on package security
PyPI is a repository for distributing packages, not a service for auditing them. While third-party security researchers and our staff do their best to detect and remove malicious packages, PyPI cannot guarantee the quality, security or suitability of any given package.
To learn more about protecting yourself from malicious actors, visit our package security documentation.