Skip to main content

Geospatial support for Odoo

Project description

License

Geospatial support for Odoo

Geospatial support based on PostGIS add the ability of server to server geojson to do geo CRUD and view definition.

Installation

To install this module, you need to have PostGIS installed.

On Ubuntu:

sudo apt-get install postgis

The module also requires two additional python libs:

for a complete documentation please refer to the public documenation

Known issues / Roadmap

  • Google layers have been removed as it was not working anyway.
  • Switching from map to form view should be eased to open selected feature. It should work using do_switch_view and this probably requires to set self.dataset.index
  • A good way to open a record from map should be done with double click. However selection handlers have difficulties to work nice with click events.

Bug Tracker

Bugs are tracked on GitHub Issues. In case of trouble, please check there if your issue has already been reported. If you spotted it first, help us smashing it by providing a detailed and welcomed feedback.

Credits

Contributors

Maintainer

Odoo Community Association

This module is maintained by the OCA.

OCA, or the Odoo Community Association, is a nonprofit organization whose mission is to support the collaborative development of Odoo features and promote its widespread use.

To contribute to this module, please visit http://odoo-community.org.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
odoo9_addon_base_geoengine-9.0.1.2.5.99.dev5-py2-none-any.whl (1.4 MB) Copy SHA256 hash SHA256 Wheel py2 Jun 29, 2018

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN DigiCert DigiCert EV certificate StatusPage StatusPage Status page