Skip to main content

Meta-package that provides the oldest supported version of Numpy

Project description

This is a meta-package which can be used in pyproject.toml files to automatically provide the oldest supported version of Numpy without having to list them all. In other words:

requires = [
    "numpy==1.13.3; python_version=='3.5',
    "numpy==1.13.3; python_version=='3.6',
    "numpy==1.14.5; python_version=='3.7',
    "numpy==1.17.3; python_version>='3.8'

can be replaced by:

requires = ["wheel", "setuptools", "oldest-supported-numpy"]

And as new Python versions are released, the pyproject.toml file does not need to be updated.

Project details

Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Files for oldest-supported-numpy, version 0.2
Filename, size File type Python version Upload date Hashes
Filename, size oldest_supported_numpy-0.2-py2.py3-none-any.whl (2.5 kB) File type Wheel Python version py2.py3 Upload date Hashes View hashes

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN SignalFx SignalFx Supporter DigiCert DigiCert EV certificate StatusPage StatusPage Status page