Skip to main content

Pandas API compatiblity layer

Project description

Build Status Version Status

pandas-compat is a package providing an API compatibility across versions to downstream libraries that use pandas.

This compatibility layer requires pandas >= 0.17.0.

Installation

Install latest release version via conda

$ conda install pandas-compat --channel conda-forge

Install latest release version via pip

$ pip install pandas-compat

Install latest development version

$ pip install git+https://github.com/pandas-compat/pandas-compat.git

Usage

In your downstream library, you can use this pattern:

import pandas_compat as pdc

pdc.is_datetime64tz_dtype(...)
pdc.infer_dtype(...)

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
pandas_compat-0.1.1-py2.py3-none-any.whl (4.2 kB) Copy SHA256 hash SHA256 Wheel py2.py3 Jun 10, 2017
pandas-compat-0.1.1.tar.gz (19.4 kB) Copy SHA256 hash SHA256 Source None Jun 10, 2017

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN DigiCert DigiCert EV certificate StatusPage StatusPage Status page