Skip to main content

Client library to simplify interacting with a polyswarmd instance

Project description

PolySwarm Client Library

pipeline status coverage report Read the Docs Build Status

For the convenience of those who wish to join the PolySwarm marketplace, this is a client library to simplify interacting with a polyswarmd instance from your Python code.

It includes:

  • abstract classes for ambassador, arbiter, and microengine implementations
  • exemplar ambassador, arbiter, and microengine implementations
  • helper classes

For important changes releases, see the Release History.

Installation

You need python3 >= 3.6.5. Then to install polyswarm-client, use pip

pip install polyswarm-client

Documentation

We have extensive documentation on how to use this package available in our docs.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Files for polyswarm-client, version 2.7.4
Filename, size File type Python version Upload date Hashes
Filename, size polyswarm_client-2.7.4-py3-none-any.whl (90.9 kB) File type Wheel Python version py3 Upload date Hashes View
Filename, size polyswarm-client-2.7.4.tar.gz (62.5 kB) File type Source Python version None Upload date Hashes View

Supported by

Pingdom Pingdom Monitoring Google Google Object Storage and Download Analytics Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN DigiCert DigiCert EV certificate StatusPage StatusPage Status page