Skip to main content
Help us improve PyPI by participating in user testing. All experience levels needed!

Check a Puppetfile for modules with newer versions

Project description

https://travis-ci.org/Mayflower/pumuckl.svg?branch=master

pumuckl (Puppet Module Version Checker) is a simple script to check a Puppetfile if there are newer module versions on the forge.

Requirements

  • Python >=3.3
  • pip(3)

Installation

To install system-wide run:

sudo pip3 install pumuckl

Alternatively you may create a virtualenv and install it there.

Usage

  • Either run pumuckl in a folder containing a Puppetfile.
  • Run pumuckl path/to/Puppetfile

Contributing

  • If you find a bug or wish to have a new feature simply open an issue.
  • Otherwise if you are really motivated pull requests are always welcome, too.

Credits

Created by Robin Gloster

Named by Tristan Helmich

License

GPLv3, see LICENSE for details.

Project details


Release history Release notifications

This version
History Node

0.2.0

Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
pumuckl-0.2.0.tar.gz (15.7 kB) Copy SHA256 hash SHA256 Source None Jun 14, 2014

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging CloudAMQP CloudAMQP RabbitMQ AWS AWS Cloud computing Fastly Fastly CDN DigiCert DigiCert EV certificate StatusPage StatusPage Status page