Skip to main content
Help us improve Python packaging – donate today!

Inject code into running Python processes

Project Description

Requirements

  • gdb (version 7.3+)

Compatiblity

Pyrasite works with Python 2.4 and newer. Injection works between versions as well, so you can run Pyrasite under Python 3 and inject into 2, and vice versa.

pyrasite-gui

The graphical interface can be found here: https://github.com/lmacken/pyrasite-gui

http://lewk.org/img/pyrasite/pyrasite-info-thumb.png

Authors

Luke Macken

http://api.coderwall.com/lmacken/endorsecount.png

David Malcolm <dmalcolm@redhat.com>

Release history Release notifications

History Node

2.0

This version
History Node

2.0beta9

History Node

2.0beta8

History Node

2.0beta7

History Node

2.0beta6

History Node

2.0beta5

History Node

2.0beta4

History Node

2.0beta3

History Node

2.0beta2

History Node

2.0beta

History Node

1.1

History Node

1.0

History Node

1.0dev

Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
pyrasite-2.0-0.1.beta9.fc16.noarch.rpm (36.5 kB) Copy SHA256 hash SHA256 RPM 2.7 Mar 24, 2012
pyrasite_2.0beta9-1_all.deb (25.1 kB) Copy SHA256 hash SHA256 Dumb Binary 2.7 Mar 24, 2012
pyrasite-2.0beta9.tar.gz (30.5 kB) Copy SHA256 hash SHA256 Source None Mar 24, 2012

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging CloudAMQP CloudAMQP RabbitMQ AWS AWS Cloud computing Fastly Fastly CDN DigiCert DigiCert EV certificate StatusPage StatusPage Status page