Skip to main content

Clickhouse backend for sigma

Project description

pySigma Clickhouse Backend

This is the Clickhouse backend for pySigma. It provides the package sigma.backends.clickhouse with the ClickhouseBackend class.

It supports the following output formats for Sigma rules:

  • default: plain clickhouse SQL querie
  • clicksiem: rule format for clickdetect

Thanks

To implement this Clickhouse backend I have leanerd a lot of code, and this is my thanks to most helpful to me.

How To

Converting sigma to clickhouse

from sigma.backends.clickhouse.clickhouse import ClickhouseBackend
from sigma.collection import SigmaCollection

rule = """
title: Run Whoami Showing Privileges
id: 97a80ec7-0e2f-4d05-9ef4-65760e634f6b
status: experimental
description: Detects a whoami.exe executed with the /priv command line flag instructing the tool to show all current user privieleges. This is often used after a privilege escalation attempt. 
references:
    - https://docs.microsoft.com/en-us/windows-server/administration/windows-commands/whoami
author: Florian Roth
date: 2021/05/05
modified: 2022/05/13
tags:
    - attack.privilege_escalation
    - attack.discovery
    - attack.t1033
logsource:
    category: process_creation
    product: windows
detection:
    selection_img:
        - Image|endswith: '\whoami.exe'
        - OriginalFileName: 'whoami.exe'
    selection_cli:
        CommandLine|contains: '/priv'
    condition: all of selection*
falsepositives:
    - Administrative activity (rare lookups on current privileges)
level: high
"""

backend = ClickhouseBackend()
rule_sigma = SigmaCollection.from_yaml(rule)
print(backend.convert(rule_sigma)[0])

Maintainer

Created an maintaned by souzo

Dev

Setup your dev environment

uv sync
source .venv/bin/activate

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Source Distribution

pysigma_backend_clickhouse-0.3.2.tar.gz (33.2 kB view details)

Uploaded Source

Built Distribution

If you're not sure about the file name format, learn more about wheel file names.

pysigma_backend_clickhouse-0.3.2-py3-none-any.whl (7.8 kB view details)

Uploaded Python 3

File details

Details for the file pysigma_backend_clickhouse-0.3.2.tar.gz.

File metadata

  • Download URL: pysigma_backend_clickhouse-0.3.2.tar.gz
  • Upload date:
  • Size: 33.2 kB
  • Tags: Source
  • Uploaded using Trusted Publishing? No
  • Uploaded via: uv/0.11.16 {"installer":{"name":"uv","version":"0.11.16","subcommand":["publish"]},"python":null,"implementation":{"name":null,"version":null},"distro":{"name":"Ubuntu","version":"24.04","id":"noble","libc":null},"system":{"name":null,"release":null},"cpu":null,"openssl_version":null,"setuptools_version":null,"rustc_version":null,"ci":true}

File hashes

Hashes for pysigma_backend_clickhouse-0.3.2.tar.gz
Algorithm Hash digest
SHA256 fa929acdedc5c0af60cce06614cd8dc65bccae3361d6f2fba0aa181f22ef3f9a
MD5 6817397f903745b14482f76334bebbec
BLAKE2b-256 49e983dd51ef5d7437e25782105ea5702104dea7dd110eb3b0248bc73392b720

See more details on using hashes here.

File details

Details for the file pysigma_backend_clickhouse-0.3.2-py3-none-any.whl.

File metadata

  • Download URL: pysigma_backend_clickhouse-0.3.2-py3-none-any.whl
  • Upload date:
  • Size: 7.8 kB
  • Tags: Python 3
  • Uploaded using Trusted Publishing? No
  • Uploaded via: uv/0.11.16 {"installer":{"name":"uv","version":"0.11.16","subcommand":["publish"]},"python":null,"implementation":{"name":null,"version":null},"distro":{"name":"Ubuntu","version":"24.04","id":"noble","libc":null},"system":{"name":null,"release":null},"cpu":null,"openssl_version":null,"setuptools_version":null,"rustc_version":null,"ci":true}

File hashes

Hashes for pysigma_backend_clickhouse-0.3.2-py3-none-any.whl
Algorithm Hash digest
SHA256 de8531b4ec6e8bb51382cda1ee44a967a119223519b038b1b628569efae2d907
MD5 47e84d4d53b762832e9f23b75da55939
BLAKE2b-256 88919a5c33938c91770ca99ec082c7a1268b502e248ef6c36ae403f30a19cf85

See more details on using hashes here.

Supported by

AWS Cloud computing and Security Sponsor Datadog Monitoring Depot Continuous Integration Fastly CDN Google Download Analytics Pingdom Monitoring Sentry Error logging StatusPage Status page