Skip to main content

A pytest plugin for test driven data-wrangling (this is the development version of datatest's pytest integration).

Project description

Travis CI Build Status MIT License

The development version of datatest’s pytest integration.

Typically, only developers working on datatest’s pytest plugin should install this package. Other users are encouraged to install just datatest—this plugin comes bundled with it.

Requirements

Installation

For Developers

Clone the git repositories and use pip to perform an editable install from the cloned project directory:

git clone git@github.com:shawnbrown/datatest.git
git clone git@github.com:shawnbrown/pytest-datatest.git
pip install --editable ./datatest
pip install --no-deps --editable ./pytest-datatest

For Users

Don’t install this package—install datatest instead:

pip install datatest

For Users With Special Requirements

If you aren’t a datatest or plugin developer but instead need bug-fixes or features that are not yet available from the main datatest project, you can install “pytest-datatest” via pip from PyPI:

pip install datatest
pip install pytest-datatest

And if the version is PyPI isn’t new enough for your needs, you can install the plugin directly from the live GitHub repository (make sure to check that the build is “passing” before doing this):

pip install datatest
pip install --upgrade https://github.com/shawnbrown/pytest-datatest/archive/master.zip

Usage

When installed, this development version automatically overrides datatest’s bundled pytest integration. If you want to revert back to the bundled plugin, simply uninstall this version.

To disable the development version (and temporarily enable the bundled version) use:

pytest -p no:datatest_devel

To disable both the development and bundled versions use:

pytest -p no:datatest_devel -p no:datatest

Features

  • Provides a ‘mandatory’ marker to support incremental testing.
  • Provides an ‘–ignore-mandatory’ command line option to override the default ‘mandatory’ behavior.
  • Strips the leading “E ” prefix from ValidationError differences to help users more easily repurpose parts of the error message for allowed.specific(...) definitions.

License

Distributed under the terms of the MIT license, “pytest-datatest” is free and open source software

Issues

If you encounter any problems, please file an issue along with a detailed description.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
pytest_datatest-0.1.2-py2.py3-none-any.whl (8.6 kB) Copy SHA256 hash SHA256 Wheel py2.py3
pytest-datatest-0.1.2.tar.gz (6.9 kB) Copy SHA256 hash SHA256 Source None

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN SignalFx SignalFx Supporter DigiCert DigiCert EV certificate StatusPage StatusPage Status page