Skip to main content

A pure python, thread-safe, minimalistic and pythonic RabbitMQ client library

Project description

A pure python, thread-safe, minimalistic and Pythonic BSD Licensed AMQP/RabbitMQ library that supports Python 2.6+ and Python 3.2+. rabbitpy aims to provide a simple and easy to use API for interfacing with RabbitMQ, minimizing the programming overhead often found in other libraries.

Version Downloads Status Coverage License

Installation

rabbitpy may be installed via the Python package index with the tool of your choice. I prefer pip:

pip install rabbitpy

But there’s always easy_install:

easy_install rabbitpy

Documentation

Documentation is available on ReadTheDocs.

Requirements

Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
rabbitpy-1.0.0-py2.py3-none-any.whl (51.0 kB) Copy SHA256 hash SHA256 Wheel py2.py3
rabbitpy-1.0.0.tar.gz (41.5 kB) Copy SHA256 hash SHA256 Source None

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN SignalFx SignalFx Supporter DigiCert DigiCert EV certificate StatusPage StatusPage Status page