Relate Python
Embeddable graph database with Cypher. Native PyO3 extension over
relate::Database.
import relate
conn = relate.connect(":memory:")
conn.execute("CREATE (:Person {name: 'Alice'})")
print(list(conn.execute("MATCH (p:Person) RETURN p.name AS name")))
Install: pip install relate-db (when published; import stays
relate) or maturin develop from surfaces/relate-python in a source
checkout. The PyPI name relate is already taken by another project.
Metadata
Release files for relate-db 1.0.0
For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.
Source distribution (sdist)
| File | Size | Uploaded | Provenance | Actions |
|---|---|---|---|---|
| relate_db-1.0.0.tar.gz | 4.5 MB | With provenance | Details for relate_db-1.0.0.tar.gz |
Built distributions (wheels)
| File | Actions Reset | |||
|---|---|---|---|---|
| relate_db-1.0.0-cp39-abi3-win_amd64.whl | CPython 3.9 | abi3 | Windows x86-64 | Details for relate_db-1.0.0-cp39-abi3-win_amd64.whl |
| relate_db-1.0.0-cp39-abi3-manylinux2014_x86_64.manylinux_2_17_x86_64.whl | CPython 3.9 | abi3 | Linux glibc 2.17+ x86-64 | Details for relate_db-1.0.0-cp39-abi3-manylinux2014_x86_64.manylinux_2_17_x86_64.whl |
| relate_db-1.0.0-cp39-abi3-manylinux2014_aarch64.manylinux_2_17_aarch64.whl | CPython 3.9 | abi3 | Linux glibc 2.17+ ARM64 | Details for relate_db-1.0.0-cp39-abi3-manylinux2014_aarch64.manylinux_2_17_aarch64.whl |
| relate_db-1.0.0-cp39-abi3-macosx_11_0_arm64.whl | CPython 3.9 | abi3 | macOS 11.0+ ARM64 | Details for relate_db-1.0.0-cp39-abi3-macosx_11_0_arm64.whl |
| relate_db-1.0.0-cp39-abi3-macosx_10_12_x86_64.whl | CPython 3.9 | abi3 | macOS 10.12+ x86-64 | Details for relate_db-1.0.0-cp39-abi3-macosx_10_12_x86_64.whl |
Total release size: 53.3 MB
Release files / relate_db-1.0.0.tar.gz
| Download URL | relate_db-1.0.0.tar.gz |
|---|---|
| Size | 4.5 MB |
| Tags | Source |
|
SHA-256 checksum How to use checksums |
ce74d295807fb8784fe459b92066b8a21bfa86ece7d209cd11be9c7899c59e64
|
|
BLAKE2b-256 checksum How to use checksums |
37ba1c7b9eee5c7ce8282bc7a1db3684b1f7ea4c0c268a1d023ee3f45e657614
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/7.0.0 CPython/3.13.16
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Nov 11, 2026.
Transparency logRelease files / relate_db-1.0.0-cp39-abi3-win_amd64.whl
| Download URL | relate_db-1.0.0-cp39-abi3-win_amd64.whl |
|---|---|
| Size | 9.9 MB |
| Tags | CPython 3.9 Windows x86-64 abi3 |
|
SHA-256 checksum How to use checksums |
89d1be14e4ddc23fdce5ef36050bc78344df822d48888d72981d7ac75fd1cd3a
|
|
BLAKE2b-256 checksum How to use checksums |
64c953f41dff2dfba194a5fa09409c96fd875cf3d7291198e9bea4764903250c
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/7.0.0 CPython/3.13.16
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Nov 11, 2026.
Transparency logRelease files / relate_db-1.0.0-cp39-abi3-manylinux2014_x86_64.manylinux_2_17_x86_64.whl
| Download URL | relate_db-1.0.0-cp39-abi3-manylinux2014_x86_64.manylinux_2_17_x86_64.whl |
|---|---|
| Size | 10.2 MB |
| Tags | CPython 3.9 Linux glibc 2.17+ x86-64 abi3 |
|
SHA-256 checksum How to use checksums |
6b3152bf3b1785282a0045bea669b17903594a2acfc87d8c615ca363d9f808af
|
|
BLAKE2b-256 checksum How to use checksums |
1868fdd36385159f3f04384c2801713b4f824b10d74adeb607dfd7311c065791
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/7.0.0 CPython/3.13.16
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Nov 11, 2026.
Transparency logRelease files / relate_db-1.0.0-cp39-abi3-manylinux2014_aarch64.manylinux_2_17_aarch64.whl
| Download URL | relate_db-1.0.0-cp39-abi3-manylinux2014_aarch64.manylinux_2_17_aarch64.whl |
|---|---|
| Size | 9.6 MB |
| Tags | CPython 3.9 Linux glibc 2.17+ ARM64 abi3 |
|
SHA-256 checksum How to use checksums |
58614644cce1a9fa4e3128d07e70ad36d0366b1f4309ebb94e8ed35363fd424e
|
|
BLAKE2b-256 checksum How to use checksums |
aedf3936c50e553b466727cd1f382e2afb5fbb6c9120bcee59bf1e8bac15d00b
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/7.0.0 CPython/3.13.16
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Nov 11, 2026.
Transparency logRelease files / relate_db-1.0.0-cp39-abi3-macosx_11_0_arm64.whl
| Download URL | relate_db-1.0.0-cp39-abi3-macosx_11_0_arm64.whl |
|---|---|
| Size | 9.2 MB |
| Tags | CPython 3.9 abi3 macOS 11.0+ ARM64 |
|
SHA-256 checksum How to use checksums |
036f8f91ce0ee27e901c12393a1c6455fc534cbfa9d4cf2463ee98239599e5b4
|
|
BLAKE2b-256 checksum How to use checksums |
79d01bf41998a378bbbd8ef3761fc845ed8c40d52d73a4f60aa64981d073d1a1
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/7.0.0 CPython/3.13.16
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Nov 11, 2026.
Transparency logRelease files / relate_db-1.0.0-cp39-abi3-macosx_10_12_x86_64.whl
| Download URL | relate_db-1.0.0-cp39-abi3-macosx_10_12_x86_64.whl |
|---|---|
| Size | 9.9 MB |
| Tags | CPython 3.9 abi3 macOS 10.12+ x86-64 |
|
SHA-256 checksum How to use checksums |
9c17e843b0e61174f37638ee9031000cf54595efb66b6f6b8168e9c97f215f2a
|
|
BLAKE2b-256 checksum How to use checksums |
c8333d4d096ba2f9e3427c5486e3abcd5d21b1eca2d2efb693f02f9760022dcc
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/7.0.0 CPython/3.13.16
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Nov 11, 2026.
Transparency logSecurity for relate-db 1.0.0
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
Full provenance
All 6 files in this release have been uploaded with provenance metadata.
Attestation for relate_db-1.0.0.tar.gz
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Nov 11, 2026.
Transparency logA note on package security
PyPI is a repository for distributing packages, not a service for auditing them. While third-party security researchers and our staff do their best to detect and remove malicious packages, PyPI cannot guarantee the quality, security or suitability of any given package.
To learn more about protecting yourself from malicious actors, visit our package security documentation.