Skip to main content
Join the official 2019 Python Developers SurveyStart the survey!

Tool to find errors in RPM packages in the context of their dependency graph

Project description

Rpmdeplint is a tool to find errors in RPM packages in the context of their dependency graph.

Requirements

  • Python 2.7

External Dependencies

In order to run the tool, the following pre-requisites need to be installed:

  • rpm, rpm-python
  • librepo, python-librepo
  • hawkey, python-hawkey

For development and tests:

  • sphinx
  • rpmfluff
  • glibc-devel.i686 and libgcc.i686, for building 32-bit binaries

Using

A user guide is provided by the man(1) page shipped with this tool:

man rpmdeplint

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Files for rpmdeplint, version 1.4
Filename, size File type Python version Upload date Hashes
Filename, size rpmdeplint-1.4.tar.gz (33.1 kB) File type Source Python version None Upload date Hashes View hashes

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN SignalFx SignalFx Supporter DigiCert DigiCert EV certificate StatusPage StatusPage Status page