Skip to main content

Extension for flake8 which uses pep257 to check docstrings

Project description

flake8-docstrings

A simple module that adds an extension for the fantastic pep257 tool to flake8.

Simply install this extension:

pip install flake8_docstrings

and run flake8.

There are no error numbers to print or ignore.

History/Changelog

0.2.0

  • Upgrade to pep257 0.3.0

0.1.4

  • Stop truncating error messages

0.1.3

  • Really fix the installation issue this time.

0.1.2

  • Actually fix the PyPI release. Ugh

0.1.1

  • Fix the PyPI release.

0.1.0

  • Initial Release!

Project details


Release history Release notifications

History Node

1.3.0

History Node

1.2.0

History Node

1.1.0

History Node

1.0.3

History Node

1.0.2

History Node

1.0.1

History Node

0.2.8

History Node

0.2.7

History Node

0.2.6

History Node

0.2.5

History Node

0.2.4

History Node

0.2.3

History Node

0.2.2

History Node

0.2.1.post1

History Node

0.2.1

This version
History Node

0.2.0

History Node

0.1.4

History Node

0.1.3

History Node

0.1.2

History Node

0.1.1

History Node

0.1.0

History Node

0.0.0

Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
flake8-docstrings-0.2.0.tar.gz (3.0 kB) Copy SHA256 hash SHA256 Source None Mar 7, 2014

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging CloudAMQP CloudAMQP RabbitMQ AWS AWS Cloud computing Fastly Fastly CDN DigiCert DigiCert EV certificate StatusPage StatusPage Status page