Skip to main content

Simple information card archive library

Project description

infocards

A small Python library for managing information cards in an archive. Supports MySQL, PostgreSQL and SQLite databases for the backend.

Compatible with Python 2 and 3.

License: GPLv2

Note: from version 0.5.0 and onwards, infocards is not backwards compatible.

Requirements

Basic requirements (installed automatically with pip) are:

If you want to use MySQL or PostgreSQL for the backend, you will also need:

Installation

Installing from source:

$ setup.py install

Installing from the Package Index (recommended):

$ pip install infocards

Documentation

Documentation is available online and contains the API reference as well as examples.

You may also build the documentation source in the docs/ directory using MKDocs.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
infocards-0.5.3-py2.py3-none-any.whl (28.8 kB) Copy SHA256 hash SHA256 Wheel 3.4
infocards-0.5.3.tar.gz (12.9 kB) Copy SHA256 hash SHA256 Source None

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN SignalFx SignalFx Supporter DigiCert DigiCert EV certificate StatusPage StatusPage Status page