Skip to main content

pySigma NetWitness backend

Project description

Test status Test coverage Package version Supported Python versions Release status

pySigma NetWitness Backend

This is the NetWitness backend for pySigma. It provides the package sigma.backends.netwitness with the NetWitnessBackend class. Further, it contains the following processing pipelines in sigma.pipelines.netwitness:

  • netwitness_windows_pipeline: NetWitness mapping and conversions for Windows

This backend is currently maintained by:

Requirements

Installation

pip install pysigma-backend-netwitness

Example

  • Create a file main.py with:
from sigma.collection import SigmaCollection
from sigma.backends.netwitness.netwitness import NetWitnessBackend
from sigma.pipelines.netwitness.windows import netwitness_windows_pipeline

netwitness_backend = NetWitnessBackend(processing_pipeline=netwitness_windows_pipeline())

conversion_result: list[str] = netwitness_backend.convert(
    SigmaCollection.from_yaml(
        """
        title: Test
        status: test
        logsource:
            product: windows
            category: process_creation
        detection:
            sel:
                CommandLine: test
            condition: sel
        """
    )
)

print(conversion_result[0])

Run the example with:

$ python main.py

reference.id = '4688' && param = 'test'

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Source Distribution

pysigma_backend_netwitness-0.2.2.tar.gz (19.9 kB view details)

Uploaded Source

Built Distribution

If you're not sure about the file name format, learn more about wheel file names.

pysigma_backend_netwitness-0.2.2-py3-none-any.whl (21.9 kB view details)

Uploaded Python 3

File details

Details for the file pysigma_backend_netwitness-0.2.2.tar.gz.

File metadata

  • Download URL: pysigma_backend_netwitness-0.2.2.tar.gz
  • Upload date:
  • Size: 19.9 kB
  • Tags: Source
  • Uploaded using Trusted Publishing? No
  • Uploaded via: poetry/2.1.1 CPython/3.12.3 Linux/6.8.0-1021-azure

File hashes

Hashes for pysigma_backend_netwitness-0.2.2.tar.gz
Algorithm Hash digest
SHA256 786809f01eecf583b113a2cf6dd9fe967dd8c26f1bcc60538cea932df9c3ff85
MD5 aaa04c192d8e3dcaae35232a5477c8f5
BLAKE2b-256 b245623b755c6b754238919ee2e1f8be61efadb06adac6d47e8337425b5fbc73

See more details on using hashes here.

File details

Details for the file pysigma_backend_netwitness-0.2.2-py3-none-any.whl.

File metadata

File hashes

Hashes for pysigma_backend_netwitness-0.2.2-py3-none-any.whl
Algorithm Hash digest
SHA256 3b3037615b868cae86a03a6d4ab0235205e5a659ff87175618e891daf42595c5
MD5 d432e77c65d967accec485ba3b0725e8
BLAKE2b-256 ee36c274b784bf7e55600bf0884141625220c2511cf4c41ddd7d5eb6df729e03

See more details on using hashes here.

Supported by

AWS Cloud computing and Security Sponsor Datadog Monitoring Depot Continuous Integration Fastly CDN Google Download Analytics Pingdom Monitoring Sentry Error logging StatusPage Status page