Skip to main content

pySigma NetWitness backend

Project description

Test status Test coverage Package version Supported Python versions Release status

pySigma NetWitness Backend

This is the NetWitness backend for pySigma. It provides the package sigma.backends.netwitness with the NetWitnessBackend class. Further, it contains the following processing pipelines in sigma.pipelines.netwitness:

  • netwitness_windows_pipeline: NetWitness mapping and conversions for Windows

This backend is currently maintained by:

Requirements

Installation

pip install pysigma-backend-netwitness

Example

  • Create a file main.py with:
from sigma.collection import SigmaCollection
from sigma.backends.netwitness.netwitness import NetWitnessBackend
from sigma.pipelines.netwitness.windows import netwitness_windows_pipeline

netwitness_backend = NetWitnessBackend(processing_pipeline=netwitness_windows_pipeline())

conversion_result: list[str] = netwitness_backend.convert(
    SigmaCollection.from_yaml(
        """
        title: Test
        status: test
        logsource:
            product: windows
            category: process_creation
        detection:
            sel:
                CommandLine: test
            condition: sel
        """
    )
)

print(conversion_result[0])

Run the example with:

$ python main.py

reference.id = '4688' && param = 'test'

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Source Distribution

pysigma_backend_netwitness-0.2.4.tar.gz (20.1 kB view details)

Uploaded Source

Built Distribution

If you're not sure about the file name format, learn more about wheel file names.

pysigma_backend_netwitness-0.2.4-py3-none-any.whl (22.3 kB view details)

Uploaded Python 3

File details

Details for the file pysigma_backend_netwitness-0.2.4.tar.gz.

File metadata

  • Download URL: pysigma_backend_netwitness-0.2.4.tar.gz
  • Upload date:
  • Size: 20.1 kB
  • Tags: Source
  • Uploaded using Trusted Publishing? No
  • Uploaded via: poetry/2.1.1 CPython/3.12.3 Linux/6.8.0-1021-azure

File hashes

Hashes for pysigma_backend_netwitness-0.2.4.tar.gz
Algorithm Hash digest
SHA256 5b6e2f8213c4e22ef5f5030d03a7b6631ea2747ae7b3d98f52164a0c5f7031cd
MD5 cb613505e74eb058a09b76cdfe4f54ba
BLAKE2b-256 546e598e680d143e91a3c1a0fdd1e72113478c8135f087aa256d82e45310c77b

See more details on using hashes here.

File details

Details for the file pysigma_backend_netwitness-0.2.4-py3-none-any.whl.

File metadata

File hashes

Hashes for pysigma_backend_netwitness-0.2.4-py3-none-any.whl
Algorithm Hash digest
SHA256 4d21b214eab978db2e9391326757576b271643ebbf2921575917cfb23273c641
MD5 722bf1444562a46ac3de970db9c1ccfd
BLAKE2b-256 9d0021f479cbf384e04df0b67c03684e75fc4e4a730855be36151667dd0175f1

See more details on using hashes here.

Supported by

AWS Cloud computing and Security Sponsor Datadog Monitoring Depot Continuous Integration Fastly CDN Google Download Analytics Pingdom Monitoring Sentry Error logging StatusPage Status page