Skip to main content
Test status Test coverage Package version Supported Python versions Release status

pySigma NetWitness Backend

This is the NetWitness backend for pySigma. It provides the package sigma.backends.netwitness with the NetWitnessBackend class. Further, it contains the following processing pipelines in sigma.pipelines.netwitness:

  • netwitness_windows_pipeline: NetWitness mapping and conversions for Windows

This backend is currently maintained by:

Requirements

Installation

pip install pysigma-backend-netwitness

Example

  • Create a file main.py with:
from sigma.collection import SigmaCollection
from sigma.backends.netwitness.netwitness import NetWitnessBackend
from sigma.pipelines.netwitness.windows import netwitness_windows_pipeline

netwitness_backend = NetWitnessBackend(processing_pipeline=netwitness_windows_pipeline())

conversion_result: list[str] = netwitness_backend.convert(
    SigmaCollection.from_yaml(
        """
        title: Test
        status: test
        logsource:
            product: windows
            category: process_creation
        detection:
            sel:
                CommandLine: test
            condition: sel
        """
    )
)

print(conversion_result[0])

Run the example with:

$ python main.py

reference.id = '4688' && param = 'test'

Metadata

Release files for pySigma-backend-netwitness 0.3.0

For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.

Source distribution (sdist)

Source distribution for pySigma-backend-netwitness 0.3.0
File Size Uploaded
pysigma_backend_netwitness-0.3.0.tar.gz 23.5 kB Details

Built distribution (wheel)

Table of built distributions (wheels) for pySigma-backend-netwitness 0.3.0
File Interpreter ABI Platform
pysigma_backend_netwitness-0.3.0-py3-none-any.whl Python 3 none any Details

Total release size: 46.8 kB

Release files / pysigma_backend_netwitness-0.3.0.tar.gz

Download URL pysigma_backend_netwitness-0.3.0.tar.gz
Size 23.5 kB
Tags Source
SHA-256 checksum
How to use checksums
3ea86cf0fa0ddddd4ea0f045a5ffef4dc59abee19b419ec45b94d629321c9514
BLAKE2b-256 checksum
How to use checksums
b68094ea32e0077833cf0bf3aa1d56e2e8ee21e255fc1ae8f6a9757af37e675d
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No
Uploaded via uv/0.9.9 {"installer":{"name":"uv","version":"0.9.9"},"python":null,"implementation":{"name":null,"version":null},"distro":{"name":"Debian GNU/Linux","version":"13","id":"trixie","libc":null},"system":{"name":null,"release":null},"cpu":null,"openssl_version":null,"setuptools_version":null,"rustc_version":null,"ci":null}

Release files / pysigma_backend_netwitness-0.3.0-py3-none-any.whl

Download URL pysigma_backend_netwitness-0.3.0-py3-none-any.whl
Size 23.2 kB
Tags Python 3
SHA-256 checksum
How to use checksums
8654cb63a40f55ba0f6a14923a67102f7110b68a6c8d0ca6cb2ed8684d7e6ca7
BLAKE2b-256 checksum
How to use checksums
a82f91887b6e5bf902f2c8d2013ce84cceb4f5c918549c6c5c698a43cd3a634c
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No
Uploaded via uv/0.9.9 {"installer":{"name":"uv","version":"0.9.9"},"python":null,"implementation":{"name":null,"version":null},"distro":{"name":"Debian GNU/Linux","version":"13","id":"trixie","libc":null},"system":{"name":null,"release":null},"cpu":null,"openssl_version":null,"setuptools_version":null,"rustc_version":null,"ci":null}

Release history Release notifications | RSS feed

This release

0.3.0 This release

2 release files

0.2.5

2 release files

0.2.4

2 release files

0.2.3

2 release files

0.2.2

2 release files

0.2.1

2 release files

0.2.0

2 release files

0.1.3

2 release files

0.1.2

2 release files

0.1.1

2 release files

0.1.0

2 release files

Anthropic, PBC Visionary sponsor Bloomberg Visionary sponsor Hudson River Trading Visionary sponsor Meta Visionary sponsor NVIDIA Visionary sponsor Microsoft Sustainability sponsor Depot Continuous Integration AWS Cloud computing and Security Sponsor Datadog Monitoring Fastly CDN Google Download Analytics Sentry Error logging StatusPage Status page