Skip to main content

Swimlane Content Migration Package

Project description

Swimlane Migrator

Installation

pip install swimlane-migrator

Change Log

0.5.4

  • Removal of bson requirement

0.5.3

  • Removal of deprecated APIs (only relevant in Swimlane <10)

0.5.2

  • Python 3 support added
  • Python 2 dropped
  • Updated authentication to API tokens

0.4.7-0.5.1 dev never deployed

0.4.6

  • Added logic to handle Selection fields with duplicate values, a situation that shouldn't occur via the app builder

0.4.5

  • Fixed issue with asset versions for 10.3

0.4.4

  • Bumped Swimlane driver version in requirements file

0.4.3

  • Fixed mapping of parent ids in workflow to prevent errors when viewing.

0.4.2

  • Fixed issue using asset as python script inputs

0.4.1

  • Fixed issue handling email assets that don't have a version number

0.4.0

  • Fixed issue causing tasks with no asset to raise error
  • Cleaned up workspace management

0.3.0

  • Email Assets are now properly migrated
  • If a swimbundle is not found it will automatically be migrated

0.2.2

  • Setup description to be displayed properly

0.2.1

  • Fixed bug that threw error when integrations had an empty input

0.2.0

  • Initial Release

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Source Distributions

No source distribution files available for this release. See tutorial on generating distribution archives.

Built Distribution

swimlane_migrator-0.5.4-py2.py3-none-any.whl (30.4 kB view hashes)

Uploaded py2 py3

Supported by

AWS AWS Cloud computing Datadog Datadog Monitoring Facebook / Instagram Facebook / Instagram PSF Sponsor Fastly Fastly CDN Google Google Object Storage and Download Analytics Huawei Huawei PSF Sponsor Microsoft Microsoft PSF Sponsor NVIDIA NVIDIA PSF Sponsor Pingdom Pingdom Monitoring Salesforce Salesforce PSF Sponsor Sentry Sentry Error logging StatusPage StatusPage Status page